Ipilot Heading Sensor Won't Pair

My ipilot lost the ability to use jog feature because I couldn’t get the trolling motor to pair with the puck sensor. The puck would flash the blue flashes like it should and when I cycled power it would come on for 3 seconds and then go off like it should yet it still wouldn’t pair via bluetooth. I tried all sorts of sequenced button pushes and powering up and down cycles all to no avail. I scoured the internet for pairing info troubleshooting and found almost nothing. That’s why I’m making this post to maybe help the next guy looking for help. Here is the advice… once the pairing capabilities fail, just replace the heading sensor puck. It was the only thing that worked for me:sunglasses:
Guess that’s what I get for letting the boat sit around for 2 months… things start to fail… cliché I know, but true. :+1:

Hey Stump…sorry this is a late reply but did you get it fixed? I had a similar problem with my Talon…the remote thought it was a Raptor. I had to work with support to get a firmware update specific to this bug.

Tight lines!


Mark Ingle 1660 SeaArk w/ 50HP Tohatsu ....Engineered to fish!!!